Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: problem with using 6 wm0 devices?!

On Mon, May 05, 2008 at 12:25:31PM -0700, Harry Waddell wrote:
> I built a set of six firewall/routers using supermicro 2U cases ( using X6DH8 
> motherboards ), 
> each with 2 onboard i82546GB nics and one pci-x card with two additional 
> i82546GB. When I added 
> an additional 2 port card to one of the routers, the new nics attached as wm0 
> and wm1. 
> I can configure wm1-wm5 up with no problems, but wm0 hangs the systems. ( 
> console responds to CR, but ifconfig doesn't return -- system is otherwise 
> unresponsive ) This fails with the GENERIC and install kernels for 4.0.
> Looking through the archives, I thought it might be an issue with kernel 
> buffers, so I increased 
> NMBCLUSTERS to 32K, but this had no effect. I also tried netbsd 4.0 AMD64, 
> but that didn't work either.
> A GENERIC ACPI INSTALL netbsd i386 -current kernel works fine ( as does 
> opensuse 10.3 ), so I think the hardware is ok, but I also tried different 
> cards just to be doubly sure. 

Could it be some interrupt routing issue ? What happens if remove the working
adapter from its PCI slot ? You can also try to swap the two adapters.

Manuel Bouyer <>
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index