Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: 4.99.60 : failed to build distribution

Quoting Alan Barrett <>:

On Tue, 22 Apr 2008, Claude Charpentier wrote:
i try to build latest current version but i got an error with
lib/libsa/memcmp.c. After discuss on #netbsd, someone tell me that memcmp.c
is no more available in sources. So i try this rm -rf /usr/src and sync
again my source tree with csup. I launch again build of ditribution and got
the same error.

That sounds like a stale dependency.  Did you remove your object
directories and/or make cleandir?

--apb (Alan Barrett)

You're right Alan, i purge /usr/obj & /usr/tools and launch again and :

NetBSD angel 4.99.60 NetBSD 4.99.60 (ZAT) #0: Tue Apr 22 18:39:42 CEST 2008 root@angel:/usr/obj/sys/arch/i386/compile/ZAT i386

All works fine

Thx a lot


Home | Main Index | Thread Index | Old Index