Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: i386 current upgrade and binary compatibility

On Friday 28 March 2008 03:47:54 Juan RP wrote:
> Something like this has been reported by a few users, looks like you
> have to rebuild libstdc++ from scratch.

No, with the gcc upgrade in current a little while back an ABI change 
happened in libstdc++ so currently its those things that _use_ libstdc++ 
need to be rebuilt.

Moving forward we need to either identify what the actual ABI change was 
and reverse it or bump the version number of the library.


Home | Main Index | Thread Index | Old Index