Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Define names in the include file for pset (was: CVS commit: src/sys)


On Tue, Jan 15, 2008 at 03:41:50AM +0000, Mindaugas Rasiukevicius wrote:
> Module Name:  src
> Committed By: rmind
> Date:         Tue Jan 15 03:41:50 UTC 2008
> Added Files:
>       src/sys/kern: sys_pset.c
>       src/sys/sys: pset.h
> Log Message:
> Implementation of processor-sets, affinity and POSIX real-time extensions.

Hmm, is it really a good idea to use defines like P_PID here?

This cause some warnings while building lsof (not that lsof build at all with
current, but thats a different problem):

In file included from ../lsof.h:191,
                 from rdev.c:43:
../dlsof.h:288:1: warning: "P_PID" redefined
In file included from /usr/include/sys/lwp.h:47,
                 from ../dlsof.h:58,
                 from ../lsof.h:191,
                 from rdev.c:43:
/usr/include/sys/pset.h:42:1: warning: this is the location of the previous 

IMHO these 3 (or 6) defines at the top of pset.h should be renamed to be more
pset specific, or are they used in other implementaions?
The bottom defines a PSET_BUSY, maybe P_ should be replaced with PSET_ and PS_
with PSETS_


Home | Main Index | Thread Index | Old Index