Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: acpi problems on acer aspire 5310

Joerg Sonnenberger wrote:
On Sun, Jan 13, 2008 at 02:47:36PM +0200, Arto Huusko wrote:
Second problem is that, even though power button and sleep button
are attached

acpibut0 at acpi0 (SLPB, PNP0C0E): ACPI Sleep Button
acpibut1 at acpi0 (PWRB, PNP0C0C): ACPI Power Button

Can you check if "vmstat -i" shows changes for irq 9 when pressing the

If you mean ioapic pin 9, then it is hard to say, because there
is constant interrupt activity there. vmstat reports rate 11.
I tried hitting the power button repeatedly while watching
"vmstat -i 1" output, but couldn't see any change in the interrupt
rate. Nor was there change in any other interrupt rates.

Hmm, watching "systat vm 1" output, I do see a change in ioapic
pin 9 interrupt rate when I press the power button repeatedly.
It seems to never go above 10 normally, but when hitting the
power button the rate does go up. The sleep button (which is
behind a Fn + normal key) does not affect the interrupt rate on
pin 9.

Third problem is that the machine will not power off with shutdown -p
(I haven't even tried sleeping it yet). Last message printed on the
console when powering off is

acpi: entering state 5

Please submit a PR for this. Include the output of acpidump with that.


Home | Main Index | Thread Index | Old Index