Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: halt(8) regression

Jukka Salmi wrote:
Jared D. McNeill --> current-users (2008-01-03 21:48:36 -0500):
Jukka Salmi wrote:

currently (4.99.48) `shutdown -h' seems not to work: after

        The operating system has halted.
        Please press any key to reboot.

is printed, pressing any key does _not_ reboot the system (at least
not those two i386 systems I tried with, using both GENERIC and
GENERIC.NOACPI kernels). Furthermore, after powering off the system
manually and restarting it, RAID parity is dirty.
My guess for the key press thing is that we've erroneously powered off your keyboard controller on shutdown. Can you comment out the calls to pmf_device_register in pckbc and wskbd?

Hmm, doesn't seem to help, I still see the problem with those calls
commented out...
I just thought I'd note that I've had this issue ever since I started tracking current ~1 year ago. All the systems I've worked on had only usb for keyboard so I never had a chance to test with ps2.

Most of them have been dell poweredges and although I rarely boot outside of a xen dom0, I'm pretty sure the problem was there with a and further back, a

I rarely ever shutdown a box and reboot has always worked so I kinda neglected to file a pr. With all the changes that have been made recently, the time frame may not even be relevent but I thought I'd mention it.


Home | Main Index | Thread Index | Old Index