tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: mixerctl with no args

    Date:        Thu, 23 Feb 2017 12:39:24 +0200
    From:        Andreas Gustafsson <>
    Message-ID:  <>

  | I suppose this is possible, but I think such cases would be rare enough
  | that there is no harm in skipping the tests on those.

Sounds reasonable.  I will do that (have done that in test sources not
yet in use anywhere...)

  | Would the tests even work if there is no audio0?

As best I can see, there are just 2 tests even remotely related to audio

The usr.bin/mixerctl/t_mixerctl test that started all of this - it just
wants the default mixer device (/dev/mixer) - what that requires be existing
in order to work I don't know.

The other is dev/audio/t_pad - that one tests audio0 and pad0 in a rump
kernel - in that environment I assume the test gets to determine that
audio does exist...

The t_pad test is working fine on the i386 b5 tests, and t_mixerctl is not.
Last time the amd64 tests worked (or approx then) t_mixerctl worked there,
and t_pad did not (but that was in mid/late Jan, and may have been while audio
was in a state of flux.)

I should have an updated mixerctl, and t_mixer committed later tonight
(my time ... it is already night here.)


Home | Main Index | Thread Index | Old Index