tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

syncthing crashes on macOS 10.13 with go 1.17

I've been tracking pkgsrc-current for a long time (several years) on a
macOS 10.13 machine.  One of the things I run is syncthing.  Until
recently, it's worked fine.

At some point over the fall,  I noticed syncthing would crash at startup
with a mysterious backtrace, and I posted about it:

Since then, RELRO has been backed out, and I rebuilt go14, go117 and
then syncthing, with no change.   So it doesn't seem to be RELRO (which
I don't want to blame unfairly, but it seems prudent to check).

Then, I built syncthing as

  make GO_VERSION_DEFAULT=116 replace

which built go116-1.16.10 as a dependency.

That build of syncthing runs fine.  It starts, it works, and is the
boring experience I want.

I have not heard of syncthing generally failing on 1.17.  I am pretty
sure that it works on NetBSD 9 with 1.17.

So my hypothesis is that go 1.17 on macOS (as built by pkgsrc) is buggy,
but I realize that's not defensible from the evidence.

Is anyone else seeing this?

Does anyone have syncthing built by go 1.17 working?

  on macOS 10.13?
  on any macOS?

Does anyone have the "syncthing crashing" syndrome?

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index