tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: MAKE_JOBS.devel/cmake ineffective

* On 2020-11-04 at 11:47 GMT, Jonathan Perkin wrote:

> * On 2020-11-04 at 11:36 GMT, Paul Ripke wrote:
> > -CONFIGURE_ARGS+=	--parallel=${MAKE_JOBS:U1}
> > +CONFIGURE_ARGS+=	--parallel=${_MAKE_JOBS_N:U1}
> Seems reasonable, but before we use this across the tree even more we
> should remove the leading _ or export a different variable as it's
> clearly not a private variable any longer.
> I'd suggest PKG_MAKE_JOBS.

Specifically this proposed diff:

That is:

 * remove _MAKE_JOBS completely
 * rename _MAKE_JOBS_N to be PKG_MAKE_JOBS
 * convert instances of ${_MAKE_JOBS} to instead be -j${PKG_MAKE_JOBS}

To me this makes more sense, and is easier to read and understand
rather than embedding the "-j".  The one difference is that now -j1
will be explicitly used when MAKE_JOBS_SAFE=no, where previously the
-j was omitted, but again to me that feels more correct anyway.

I'm happy to test this in a bulk build if preferred.

Jonathan Perkin  -  Joyent, Inc.  -

Home | Main Index | Thread Index | Old Index