tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: libidn2 question

Niclas Rosenvik transcribed 2.0K bytes:
> On Wed, 30 Oct 2019 20:41:58 +0000
> ng0 <> wrote:
> > Niclas Rosenvik transcribed 437 bytes:
> > > On Wed, 30 Oct 2019 17:58:09 +0000
> > > ng0 <> wrote:
> > >   
> > Do you have any idea what I could be looking into, pkgsrc
> > and libidn2 related?
> > 
> > Thanks! 
> I don't know really but I believe that the problem is in the configure
> script. Setting --with-libidn2 makes configure search for idna.h when
> it should search for idn2.h. I tried using --with-libidn=no without
> setting --with-libidn2, that makes configure search for idn2.h after
> it finds libidn2. --with-libidn2 disables search of idn2.h for me at
> least. And for me it is the same behavior of I call ./configure
> directly as if I run bmake configure. You can try to have
> --with-libidn=no in instead of
> --with-libidn2=${BUILDLINK_PREFIX.libidn2} and see how that works.
> I know its a little backwards to have the idn option turn of libidn but
> it seems to work.

Thanks for testing this. It it least indicates that I need to make
changes to the way this is detected in configure for the next

Home | Main Index | Thread Index | Old Index