tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bump req libxcb

Thomas Klausner <> writes:

> On Thu, Mar 30, 2017 at 04:03:31PM -0400, Greg Troxel wrote:
>> writes:
>> > libXest is failing on netbsd-6-0:
>> >
>> > configure: error: Package requirements (xproto >= 7.0.13 x11 >= 1.6
>> > xextproto >= 7.1.99) were not met:
>> >
>> > Package dependency requirement 'xcb >= 1.11.1' could not be satisfied.
>> > Package 'xcb' has version '1.7', required version is '>= 1.11.1'
>> I've been thinking about this, plus had a few off-list exchanges.  It
>> felt too scary to try to fix during the freeze.
>> My current thought is that the real issue here is that libX11 itself,
>> when built from pkgsrc, needs the new xcb.  So there should be some way
>> to have libX11's bl3 file impose the requirement when the pkgsrc version
>> is selected, sort of
>> .if we-are-using-pkgsrc-libX11
>> BUILDLINK_API_DEPENDS.libxcb+=	libxcb>=1.11.1
>> .endif
>> Does that make sense?
> No. There is no problem for the pkgsrc version, since it already pulls
> in 1.11.1 (see libX11/Makefile). The problem is only for the native
> version.

Have you built libXext on a netbsd-6 system?

When you build libX11 on netbsd-6, then it does require xcb 1.11.1 and
gets xcb 1.12.  It builds fine, and the resulting package depends on
xcb. The installed .pc file expresses a depenency on xcb >= 1.11.1

However, when something buildlinks against libX11 and that ends up
choosing the pkgsrc version, libX11's bl3 file does not have any
requirement on xcb, and thus the native xcb is used.  Then linking of
libX11 fails.

In libXext's case, it needs libX11 >= 1.6 (I don't know why).  The
netbsd-6 installed version is 1.4.4.  So it uses the pkgsrc version.
But then including libX11's bl3 does not include xcb in the bl3'd libs,
and this is wrong.

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index