tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bump req libxcb writes:

> libXest is failing on netbsd-6-0:
> configure: error: Package requirements (xproto >= 7.0.13 x11 >= 1.6
> xextproto >= 7.1.99) were not met:
> Package dependency requirement 'xcb >= 1.11.1' could not be satisfied.
> Package 'xcb' has version '1.7', required version is '>= 1.11.1'

I've been thinking about this, plus had a few off-list exchanges.  It
felt too scary to try to fix during the freeze.

My current thought is that the real issue here is that libX11 itself,
when built from pkgsrc, needs the new xcb.  So there should be some way
to have libX11's bl3 file impose the requirement when the pkgsrc version
is selected, sort of

.if we-are-using-pkgsrc-libX11
BUILDLINK_API_DEPENDS.libxcb+=	libxcb>=1.11.1

Does that make sense?

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index