tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: lang/oracle-jre8 not working on Darwin

On 03/27, J. Lewis Muir wrote:
> On 03/27, J. Lewis Muir wrote:
> > Hello!
> > 
> > On macOS Sierra, with pkgsrc-current, for lang/oracle-jre8
> > doesn't seem to be working because it's not detecting that I have a
> > built-in version installed.  (This may not be due to a recent change
> > since I haven't tried building it in a while.)  It doesn't even seem to
> > assign a value to
> > 
> > ===
> > $ bmake show-var
> > 
> > ===
> Hmm, well, I think one thing is that maybe this won't work?  I guess I
> need to be doing this in the package directory of something that depends
> on the package that I'm expecting to be provided as a builtin?  With
> that in mind, I tried from devel/apache-ant, and now I get:
> ===
> $  bmake show-var
> no
> ===
> So, it's not picking that up.  Now to figure out why not....

OK, so the problem is that the built-in JRE does not exist inside my
build sandbox:

$ bmake show-var VARNAME=_JRE_HOME
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home
$ ls '/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home'
ls: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home: No such file or directory

In this case, I'm using the sandbox created by pkg_comp.  So, I need to
figure out how to get that path mounted in the sandbox.


Home | Main Index | Thread Index | Old Index