tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: OSX: No suitable Xcode SDK or Command Line Tools installed [patch/hack]

Hubert Feyrer <> writes:

> My bad - I use 10.10.5, not 10.9 - and I use the packages built on the
> same 10.10.5 system.

That's ok - the exact version is not really the point.

But presumably you are building with the 10.11 SDK on 10.10, and that's
an incorrect thing to do (well, if you try to run them, vs transport
them to a 10.11 system).

> Below is what pkg_info says (excluding dependencies) and what seems to
> work for me.

Sure, many things will work.

>> I had a similar experience earlier, where many programs worked and
>> some failed to run becuase of a missing symbol.  That and others
>> having similar issues others led to pkgsrc making sure it was using
>> the SDK appropriate for the running system, rather than the default
>> SDK (which was inexplicably not the running system).
> Can you name a few pkgs which I can try to find out if things are
> indeed bad here?

Sorry, memory is fuzzy -- but it might have been wireshark.  My problem
was in using a 10.10 sdk under 10.9, though, which is a different set of

There was some libc function that got added in the new version, and then
wireshark used it because configure found it, but it wasn't found in the
old version actual libc.dylib.  I ran diff -ur between the 10.9 and
10.10 SDK /usr/include and got 60K lines of diff, so it's hard to spot
the extra system call.

I have no idea if this is true between 10.10 (that you are running) and
10.11 (that you are building for).  But it seems not just an unwarranted
leap but unlikely that the ABI of 10.11 is precisely that of 10.10, with
no additions.

> As for adding comments, I agree, too, if that’s the only missing thing
> - which it doesn’t look to me right now.

I am afraid it isn't.  I think jperkin and I object to the whole notion
of using a wrong sdk, and certainly of having it happen by default.  But
I couldn't resist pointing out that the code was not understandable
about why it was doing what it was.

Why don't you want to install the command line tools?

Does anybody have a bug open with Apple?  Is there anyone from Apple on
the list who could nudge people to fix this?

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index