tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: First go at adding GCC_VERSIONS_ACCEPTED support

On 21/10/15 02:47, Leonardo Taccari wrote:
Hello Greg, Jonathan and all tech-pkg@ readers,

Greg Troxel writes:
Jonathan Perkin <> writes:
./www/webkit-gtk/Makefile:GCC_REQD+=	4.9
Not on 2015Q3, so this is recent.  Is this something that can be worked
around?  It is seeming like the world is getting crazy with more and
more recent toolchain requirements.
Yes, webkit-gtk-2.10.0 (and newer versions) needs gcc>=4.9.

For more information please give a look here:

It is needed only by IndexedDB and I think it is possible to disable it
in order to go back to require gcc-4.7 or gcc-4.8 if needed (and then
patching Source/cmake/OptionsGTK.cmake to not require 4.9).

It's hard to track down exactly what this bug is all about. As far as I can tell they decided it was easier to update their test systems to a distribution providing GCC 4.9 and make that the minimum requirement, than it was to analyse and address some not well defined problem.

It'd be annoying to require 4.9 as the C++ minimum Pkgsrc-wide if the sole need is to obscure a bug in webkit-gtk...

Home | Main Index | Thread Index | Old Index