tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: netbsd32_compat packages

Robert Swindells <> writes:

> Greg Troxel wrote:
>>Robert Swindells <> writes:
>>> Is there a reason we don't have a netbsd32_compat package for anything
>>> later than 4.0 ?
>>I don't think there are any good reasons not to have them.  I am
>>guessing it's just lack of round tuits.
>>It's not entirely clear which versions should exist.   I gather there
>>was some incompatable ABI change in X somehow in either 5 or 6.
> It shouldn't make any difference whether there was an ABI change.

I believe that the fact that we have both a compat60 and compat61 is
because there was an ABI change from 6.0 to 6.1.  Otherwise binaries
built under 6.0 would just work under 6.1 with no need for compat files,
and we'd only have compat60 (to bridge from 6.0 to 7.0).
compat60 is just libpthread.

>>> I had a go at creating netbsd32_compat61 by cutting and pasting stuff
>>> from the 4.0 package and it seems to work ok.
>>So that's libraries that allow one to run binaries compiled under 6.1 on
> The libraries allow you to run e.g. i386 binaries compiled under 6.1
> on amd64 netbsd-6 or netbsd-7. Should work for mips/mips64 and
> sparc/sparc64 too.

I think it's the notion of using this for i386 binaries built on 6.1 for
amd64 6.1.  amd64 6.1 by default has a populated /usr/lib/i386 (or at
least netbsd-6 does).

Attachment: pgpYMVdTsBGsW.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index