tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Naming convention for Ruby packages?


In message <>
        on Tue, 18 Mar 2008 13:24:13 +0900,
        "OBATA Akio" <> wrote:
> > graphics/rabbit
> I don't want to add ${RUBY_PKGPREFIX}.
> Package users don't mind if it depend on ruby or not.
Yes.  But, adding ${RUBY_PKGPREFIX} has another aspect that multiple
binary packages could easily coexist.  (So, I prefer to prefix for

> Should we use something like ${RUBY_PKGSUFFIX} instead?
Is it easily done?

> > graphics/x11rec
> > sysutils/pdumpfs
> Those packages are just a ruby script.
> I want to avoid to depend on particular ruby version.
These might be depends on lang/ruby or ruby{18,19}-base with 

Takahiro Kambe <>

Home | Main Index | Thread Index | Old Index