Port-sgimips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Intel GigE or other 64-bit PCI cards on O2?

Another "does this work for you" query -- I've had trouble with the Intel 82544EI on the O2 ever since when... I tried again with a recent -current, and still get the same spotty functionality -- large tcp transfers hang, the nic fails to respond occasionally, etc.

wm0 at pci0 dev 3 function 0: Intel i82544EI 1000BASE-T Ethernet, rev. 2
wm0: interrupting at crime interrupt 10
wm0: 64-bit 33MHz PCI bus
wm0: 64 word (6 address bits) MicroWire EEPROM
wm0: Ethernet address ....
makphy0 at wm0 phy 1: Marvell 88E1000 Gigabit PHY, rev. 0

There's also an odd message re: PCI configuration:

PCI bus 0: Warning: Total bandwidth exceeded!?

The other thing of note is what 'netstat -i' reports:

Name  Mtu   Network       Address      Ipkts Ierrs    Opkts Oerrs Colls
wm0   1500  <Link>        <macaddr>    11564  9431        7     0     0

That's after a *succesful* 'ping -f -c 10000' from another node... and an attempted 'scp' of /netbsd (~ 7MB) from the sparc64 box.


Home | Main Index | Thread Index | Old Index