Port-sgimips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Intel GigE or other 64-bit PCI cards on O2?

Rafal Boni wrote:
Another "does this work for you" query -- I've had trouble with the Intel 82544EI on the O2 ever since when... I tried again with a recent -current, and still get the same spotty functionality -- large tcp transfers hang, the nic fails to respond occasionally, etc.

The other thing of note is what 'netstat -i' reports:

Name  Mtu   Network       Address      Ipkts Ierrs    Opkts Oerrs Colls
wm0   1500  <Link>        <macaddr>    11564  9431        7     0     0

That's after a *succesful* 'ping -f -c 10000' from another node... and an attempted 'scp' of /netbsd (~ 7MB) from the sparc64 box.

Oops, classic "oops, forgot something moment"... this and mec0 were both on the same network... the sent-packet count of mec0 actually made sense given the traffic. So there's just the question of the input errors.

All that said, TCP *does* seems to provoke this more than ICMP, but I'll actually have to test it in a more sensible configuration (ie, w/out two NICs on the wire/same IP network)


Home | Main Index | Thread Index | Old Index