Port-hpcsh archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Key auto-repeat not working in X

On Thu, Aug 18, 2005 at 04:05:38PM -0400, Michael Wileman wrote:
> Christer,
> If you get a chance, can you send me your config files. I guess that 
> would be xf86config, .xinitrc and the init for whatever window manager 
> you are using. I use fvwm2.
> Also, do you start X using startx or some other way, and as root or 
> not?
> Thanks,
> Mike

Hi Mike,

Sure, but I haven't got many init files. I have tried the bog
standard twm, and no particular .xinitrc, just the standard xinitrc
in /etc/X11/xinit.

I have also tried with evilwm, and a .xinitrc I am attaching.
Evilwm doesn't use any other init file. I don't seem to have any
XF86Config or xf86config. I guess it runs on default values.

I am starting X with startx as an ordinary user.

Key repeat works in both the above cases for me. I _think_ my
userland is 3BETA, from a binary snapshot.

Christer Andersson
# Sample .xinitrc for starting evilwm

# Merge X resources from ~/.Xdefaults
[ -f $HOME/.Xdefaults ] && xrdb $HOME/.Xdefaults

# Set the background and root cursor shape
xsetroot -solid \#400040
xsetroot -cursor_name top_left_arrow

# Start evilwm - snap to borders within 10 pixels, xclock starts fixed
# xterm a bit smaller
/usr/pkg/bin/evilwm -snap 10 -app xclock/XClock -v 0 -app xterm -g 80x15+20+5&
#/usr/pkg/bin/evilwm -snap 10 &

# Transfer control to xclock - killing xclock (with Ctrl+Alt+Escape, say)
# will exit our session
#exec xclock -digital -update 1 -padding 2 -g -0+0
exec xclock -digital -padding 2 -g -0+0

Home | Main Index | Thread Index | Old Index