Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD 10.0_BETA on RPI zero 2

  I am running both an upgraded 9.x and a fresh 10.0 beta on 2
Raspberry Pi Zero 2W models. I followed these steps:


$ uname -a
NetBSD aaa 10.0_BETA NetBSD 10.0_BETA (GENERIC) #0: Fri Jan 13
19:15:32 UTC 2023
$ file /netbsd
/netbsd: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV),
statically linked, for NetBSD 10.0, not stripped

I have had one incident with an ethernet adapter not behaving well,
but otherwise testing has gone well.

On Sun, Feb 19, 2023 at 6:22 PM Dave Tyson <dtyson%anduin.org.uk@localhost> wrote:
> Has anyone has any success booting a RPI zero 2 with an armv7.img.gz
> image from NetBSD 10.0_BETA?  I have tried both a homebuilt x-compiled
> image and also one from the releng site - both fail to boot.
> IIRC I managed to boot this pi with 9.99.xxx from around a year ago,
> but all recent attempts with 10 fail - I just get the coloured screen.
> Reports of success (with any fixups) appreciated. I have tried the
> original dtb fix of copying bcm2837-rpi-3-b-plus.dtb bcm2710-rpi-zero-
> 2-w.dtb
> Cheers,
> Dave

Home | Main Index | Thread Index | Old Index