Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Raspberry 4 installation?

wiz%NetBSD.org@localhost (Thomas Klausner) writes:

>> An 8GB model ?

The 8GB model lacks the firmware EEPROM for the USB controller,
instead it is part of the GPU firmware and gets pushed to the
USB controller.

>> You need a newer version of start4.elf and fixup4.dat and
>> copy that to the FAT partition.

>I copied the latest versions of these files from
>https://github.com/raspberrypi/firmware to the DOS partition and
>booted - now I just get a black screen.

A serial console is usually easier to follow.

>Then I tried replacing all of startup*, fixup* and bootcode.bin from
>the repository, same result.

RPI4 just uses start4.elf/fixup4.dat. The cd/db/x files are
cut-down (disabled GPU features), debug and extended (needed for
camera) variants.

bootcode.bin isn't used, the code is in an EEPROM instead.

>Is there a way to get it to tell me what the issue is?

Add a serial console. A line 'uart_2ndstage=1' in config.txt
will make the firmware verbose.

I'll fetch arm64.img.gz from nycdn to see what is missing..

Home | Main Index | Thread Index | Old Index