Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Illegal instruction errors on RPI3 with NetBSD-8


On Thu, Aug 03, 2017 at 04:29:09PM -0700, Brian Buhrow wrote:
> If I build using:
> ./build.sh -N 2 -D /var/tmp/netbsd-rpi -O /usr/local/netbsd/obj-rpi -m evbarm -a earmv6hf -j 4 -U release
> I get the rpi2.img file, with a good kernel on it, but the userland
> binaries give me the illegal instruction errors.

I finally got around to running a few tests.  Based on a HEAD tree
from Jul 30 I ran "build.sh release" with both -a earmv6hf and -a
earmv7hf.  Both userlands (v6 and v7) worked with both (v6 and v7)
builds of the RPI2 kernel.  I didn't test very much but sshd always
worked (only v6 link local addressing, but still, the interface has to
be "ifconfig up"'d first, and I'm also (so far) not seeing any
"Illegal instruction" errors.

I don't know what went wrong there for your build, the biggest
difference I can see right now is that I did not use "-j 4" (well, and
that you used netbsd-8).

But it seems that basically both builds, earmv6hf and earmv7hf should
work, and you are even allowed to mix kernel and userland betwen them
(e.g., earmv7hf kernel and earmv6hf userland).

Not sure if this helps in any way...


Home | Main Index | Thread Index | Old Index