Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Allwinner H3 support added to -current

Hi Jared

Thank you very much. It works now.

Yours Yuqing.

On 07/09/2017 06:42 PM, Jared McNeill wrote:
Hi Yuqing --

You must be using bash as /bin/sh to get that error? If so I've checked in a fix. Thanks for the report!


On Sun, 9 Jul 2017, Yuqing.Guo wrote:

Hi Jared

I try to do an release building today, but it failed with the flowing error.
   >> src/distrib/utils/embedded/conf/armv7.conf: unexpected '}'

unless to comment out the "populate_sunxi()" function in armv7.conf.

Can you check out this?

Thank you.
Your Yuqing.

On 07/08/2017 07:52 AM, Yuqing.Guo wrote:
Hi Jared

Oh, this is an excellent feature!
I will update my source tree and confirm this.

Thank you for your effort^_^

Yours Yuqing

On 07/07/2017 06:55 AM, Jared McNeill wrote:
This should all be working now -- there should now be an installation/ramdisk/ramdisk.ub as part of your release build.


On Wed, 5 Jul 2017, Jared McNeill wrote:

Fantastic news Yuqing! I'll hook this up to the build once I figure out how :)


On Wed, 5 Jul 2017, Yuqing.Guo wrote:

Hi Jared:

It is great!!
Using ramdisk to boot the installer SUCCEED!
See the attached dmesg, please.

Thank you, Thank you!

And wait your commit for including a ramdisk.fs/ramdisk.ub in the release build.

Yours Yuqing.

On 07/05/2017 08:06 PM, Jared McNeill wrote:
Hi Yuqing --

Thank you for the dmesg. Very excited to see other boards working with no changes.

I've committed support for another way to boot the installer, but haven't tested the entire process yet. Please try it and let me know how it goes.

If you do a full release build, there should be a 'ramdisk.fs' somewhere in the obj directory (I think). This is normally used as an embedded ramdisk image in the *_INSTALL kernels.

Instead, add a legacy U-Boot header to the ramdisk.fs file (make sure your mkubootimage is up to date, I checked in a fix for this last night):

$ mkubootimage -A arm -C none -O linux -T ramdisk -a 0 -n "NetBSD/sunxi ramdisk" ramdisk.fs ramdisk.ub

Copy 'ramdisk.ub' along with the 'netbsd.ub' from the SUNXI kernel to your SD card. Try booting like this:

 setenv kernel netbsd.ub
 setenv ramdisk ramdisk.ub
 fatload mmc 0:1 ${kernel_addr_r} ${kernel}
 fatload mmc 0:1 ${fdt_addr_r} ${fdtfile}
 fdt addr ${fdt_addr_r}
 fatload mmc 0:1 ${ramdisk_addr_r} ${ramdisk}
 bootm ${kernel_addr_r} ${ramdisk_addr_r} ${fdt_addr_r}

If all goes well, it should use the ramdisk.ub file for the root fs and start the installer.

If this works, I'll remove the SUNXI_INSTALL kernel and include a ramdisk.fs/ramdisk.ub in the release build instead.


On Wed, 5 Jul 2017, Yuqing.Guo wrote:

Hi Jared:

I attached the dmesg of booting Orange Pi PC Plus.

I will try the flowing method as you mentioned to boot an install.ub.
Thank you again!

Yours Yuqing.

On 07/05/2017 07:15 AM, Jared McNeill wrote:
On Tue, 4 Jul 2017, Jared McNeill wrote:

Not sure yet how to boot with "go". I tried converting the .bin to a Legacy U-Boot image like this:

$ mkubootimage -A arm -C none -O linux -T kernel -a 40008000 -n "NetBSD/sunxi install" install.bin install.ub

Oops, there's a typo in that command -- the -a value needs to be specified in hex, so the correct command would be:

$ mkubootimage -A arm -C none -O linux -T kernel -a 0x40008000 -n "NetBSD/sunxi install" install.bin install.ub

Still need to increase CONFIG_SYS_BOOTM_LEN though.


Home | Main Index | Thread Index | Old Index