Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Allwinner H3 support added to -current

Hi Yuqing --

That's great news! Can you post a dmesg somewhere?

Not sure yet how to boot with "go". I tried converting the .bin to a Legacy U-Boot image like this:

  $ mkubootimage -A arm -C none -O linux -T kernel -a 40008000 -n "NetBSD/sunxi install" install.bin install.ub

however I ran into a size limitation in the stock U-Boot config:

=> boot
reading install.ub
10646484 bytes read in 496 ms (20.5 MiB/s)
reading sun8i-h3-orangepi-plus2e.dtb
16775 bytes read in 48 ms (340.8 KiB/s)
## Booting kernel from Legacy Image at 42000000 ...
   Image Name:   NetBSD/sunxi install
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    10646420 Bytes = 10.2 MiB
   Load Address: 02627940
   Entry Point:  02627940
   Verifying Checksum ... OK
## Flattened Device Tree blob at 43000000
   Booting using the fdt blob at 0x43000000
   Loading Kernel Image ... Image too large: increase CONFIG_SYS_BOOTM_LEN
Must RESET board to recover

So I guess if you increase that option it could work.

Sorry I couldn't be of more help.


On Tue, 4 Jul 2017, Yuqing.Guo wrote:

Hi Jared:

Today, I tested my Orange Pi PC Plus board first.
I am glad to tell you that, the kernel(netbsd.ub) boot the board without any problem!!
And the internal 8G-emmc works well too!

But I have one question:
How do I boot the install kernel (netbsd_INSTALL.bin) with u-boot's "go" command and with ${fdt_addr_r} specified?

Thanks you for your help!

Yours Yuqing.

On 07/03/2017 09:09 PM, Yuqing.Guo wrote:
Hi Jared

It is going to work, now!

Thank you very much!

I will test the NanoPi-M1 board from now...

On 07/03/2017 08:52 AM, Jared McNeill wrote:
Hi Yuqing --

Sorry about that! I've checked in the of_match_compat_data code.

Thank you for pointing out the __HAVE_CPU_UAREA_ALLOC_IDLELWP problem, my tree was out of date. I've committed this change to std.sunxi as well.


On Mon, 3 Jul 2017, Yuqing.Guo wrote:

Hi Jared McNeill,

Thank you for your great work!!

I tried to compile kernel, but there is one error.
src/sys/arch/arm/sunxi/sunxi_emac.c:1324:9: error: implicit declaration of function 'of_match_compat_data' [-Werror=implicit-function-declaration]
Can you fix this?

I have put the flowing into the std.sunxi config file. Otherwise, pre-compile error occurred.

Thank you again.

Yours Yuqing.

On 06/30/2017 06:39 AM, Jared McNeill wrote:
On Thu, 29 Jun 2017, Jared McNeill wrote:

6. Reset the board and hopefully things work for you.

Of course it won't work because I missed the step where you have to copy the kernel (netbsd.ub) and the correct .dtb file to the MSDOS partition on the SD card.

Good luck!

Home | Main Index | Thread Index | Old Index