Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Configuring kernel with multidisk swap

Its relatively simple, really:

make sure GENERIC is commented out of the kernel config file.

Then put in a config line for the partitions something like:

confg netbsd root on sd0a swap on sd0b and sd1b and sd2b

Per Bojsen <pb%delta.dk@localhost> recently wrote:
>I've been trying to configure a new kernel that allows me to swap on
>more than one disk, but has not been successful so far.  Here's what
>I've done:
>1) I started by changing the `config netbsd swap on generic' line to
>`config netbsd swap on sd2b sd1b' (sd2 is my main NetBSD disk, and
>where my root partition and swap partition is; sd1 is the disk I want
>to swap to besides sd2), but config reported syntax error on the
>config line.  Hmm.
>2) I checked the NetBSD mail archives and it didn't reveal the syntax
>error.  I then checked the config source and found out that you have
>to add an `and' between the swap partitions.  So I changed the config
>line to: `config netbsd swap on sd2b and sd1b'.  Now config reported
>`no root disk specified'.
>3) Ok, I then added a root specification and a dumps specification,
>also, just for completeness, so the config line was changed to:
>`config netbsd root on sd2a swap on sd2b and sd1b dumps on sd2b'.
>This allowed config to run successfully.  I did `make depend', and
>compiled the kernel, but the final link failed with `undefined symbol
>_setconf referenced from autoconf.o'.
>4) I checked autoconf.c and found that when GENERIC is #define'd the
>setconf() function is called.  This function is defined in
>swapgeneric.c which is included in the kernel build when using `swap
>on generic'.  But when you're not using that, config produces a
>swapnetbsd.c source file, which does not include setconf().  Ok, I
>removed `options GENERIC' from the configuration and re-config'd and
>recompiled, and finally the build succeeded.
>But when I rebooted using the new kernel the boot failed with `exec
>/sbin/init error 12' and `panic: no init'.  This sounds like the wrong
>partition was selected as root.  Hmm.  I'm positive sd2a is my root
>partition when running my normal kernel (the one with `swap on
>generic').  Does the removal of the GENERIC option and/or the change
>of root/swap/dumps options change the way disk devices are named?  
>I also tried `config netbsd root on sd2 swap on sd2 and sd1 dumps on
>sd2' with the same result.  And I tried to `make clean' before
>recompiling with the same result.  Is there something obvious I'm
>missing?  The kernel configuration is basically GENERIC with
>unnecessary options removed (device drivers for non-existent hardware,
>for instance).
>Per Bojsen                                   Email: pb%delta.dk@localhost
>DELTA IC Design                                     
>Venlighedsvej 4, Hoersholm, Denmark

 Eric Mehlhaff, mehlhaff%crl.com@localhost

Home | Main Index | Thread Index | Old Index