Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Land of the rising LUN

good news!  1.1 is now up on our A3kT [a gig disk for NetBSD,
2mCHIP/8mFAST, currently one A2065 [soon 2 as a LAN bridge/gateway]
and 7-way CD-jukebox for export via NFS and Samba.  many kudos to the
team, 1.1 took just over an hour for a ground-up install, and worked
first time.  [the binary download took all night, but that's another
story.  getting initial NFS exporting was a breeze - the learning
curve was 0 compared to last time ;-]

another-BSD-dude-name-unknown-okay-i-lost-the-mailspool noted LUN use
had filtered thru to the Amiga port under 1.1 [their drive was having
a spakky fit on startup], and indeed GENERIC spots the CD jukebox
correctly, making cd0, cd1, cd2, cd3, cd4, cd5 and cd6 come up with

'ahsc0: targ 4 lun X: <NRC, MBR-7, 110> SCSI2 5/cdrom removeable'

which is good so far.  the first platter [cd0] mounts fine with
'mount_cd9660 -o ro /dev/cd0a /mnt/cd1', as it used to on the 1.0 box
- however, going for cd1a and friends doesn't go too well, and
returns 'device not configured' [i've tried umounting one CD before
mounting another, no difference...]

i've gone thru and manually created the nodes for the extra cd
devices with mknod [following OReilly's EssSysAdm, mimicing the
c|b|major|minor properties of cd0a [each LUN *appears* to look like a
new disk as opposed to another partition of a single device] as
MAKEDEV isn't jukebox-aware, but no luck yet.  LUNs are enabled on
the controller [the Amiga side can swap platters], so it's one of the

[a] my device config needs tweaking [easy]

[b] GENERIC has LUN support = i need to engage it and rebuild kernel,
although there's nothing much about LUNs in the config file.

[c] NetBSD 1.1 has *partial* LUN support, and can spot LUN-friendly
devices but not access past the first one.

is anybody else making use of LUNs in their systems?  apart from CD
jukeboxes, i can't think of other devices that use 'em, so i may be
on my own....  [expect some install-docs on the subject if so]

and yes, [c] *is* possible, - my first downloaded NetBSD 1.0 kernel
had NFS mount/export support rolled in [you could mount devices from
remote machines], but wouldn't actually *send or recieve* any data in
or out and just created 0-length files.  this was hell to work out,
as it was also my first ever NetBSD kernel, and no book mentioned
this was possible.  hence i kept asking stupid questions last year...]

ideas?  comments?  fish?  LUN-users?  once again, many thanks to the
development crew, as it's saved me from hating running NT for our
central servers, and protects them from my boss, who doesn't know
unix whatsoever and thus can't screw everything up terminally ;-]


thp/c!truS'96 mail://thp%cix.compulink.co.uk@localhost / thp%mono.org@localhost

[on the gateway side, 2 ethernet cards when booting the generic
kernel panics the system every time, but that's to be expected.
rebuilds are imminent once the jukebox is sorted out - i note that
most of the networking options i found that made 1.0-builds fall over
had been commented out by Chris H for 'GENERIC', as well.  i could
always go for 3 2065s and an Ariadne [hey, it's a tower, we've got
slots] and really hammer the le0 drivers, but that's a bit overkill ;-]

[incidentally - the ftp.doc.ic.ac.uk mirror didn't have MAKEDEV in
the /dev directory [i just copied it from our 1.0-running LAN
fileserv] - should it have been included in the binary release?]

Home | Main Index | Thread Index | Old Index