pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Build failures with gobject_introspection / gvfs

As the originator of the PR you referenced, I am puzzled that you seem to
be having the same problem we thought was fixed at the time.

The only difference is that I was on amd64/i386/macppc and you are using

I take it you've worked through the diagnostic steps in the PR to reach
your determination that having "gvfs" installed breaks

Failing finding another toolchain quirk similar to that found before, I
can only recommend adding something like:


to your "/etc/mk.conf" file and rebuilding "xfce4-thunar" (and uninstalling
any previously-installed "gvfs" package).

Even after the PR was shown to be fixed, I continued to build with
"PKG_DEFAULT_OPTIONS+= -gvfs" because "gvfs" interferred with the use
of "amd"-managed removable media (it would grab the media upon mount
and keep it open, preventing unmounting).

These days I don't build anything that would ever use it, so I haven't
tried in a long time.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]consolidated[flyspeck]net  OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index