pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Can't bootstrap pkgsrc on Solaris 10

I created a new zone in which I installed gcc5 from opencsw.

-bash-3.2# /opt/csw/bin/pkgutil -l | grep gcc
-bash-3.2# /opt/csw/bin/gcc --version
gcc (GCC) 5.2.0

Bootstrap worked without changing "_OPSYS_SUPPORTS_SSP". Unfortunnaly it end up the same way as the old zone in which I bootstraped pkgsrc with gcc 3.4.3 from SunFreeWare.

-bash-3.2# cd /usr/pkgsrc/sysutils/osname/
-bash-3.2# cat nohup.out
=> Bootstrap dependency digest>=20010302: NOT found
=> Verifying package-install for ../../pkgtools/digest
===> Skipping vulnerability checks.
WARNING: No /usr/pkg/pkgdb/pkg-vulnerabilities file found.
WARNING: To fix run: `/usr/pkg/sbin/pkg_admin -K /usr/pkg/pkgdb fetch-pkg-vulnerabilities'.
===> Installing dependencies for digest-20160304
=> Build dependency gcc2>=2.95.3nb7: NOT found
=> Verifying package-install for ../../lang/gcc2
=> Bootstrap dependency digest>=20010302: NOT found
=> Verifying package-install for ../../pkgtools/digest
ERROR: This package has set PKG_FAIL_REASON:
ERROR: Circular dependency detected
*** Error code 255

bmake[3]: stopped in /usr/pkgsrc/pkgtools/digest
*** Error code 1

bmake[2]: stopped in /usr/pkgsrc/lang/gcc2
*** Error code 1

bmake[1]: stopped in /usr/pkgsrc/pkgtools/digest
*** Error code 1

bmake: stopped in /usr/pkgsrc/sysutils/osname

I tried with the "vanilla" mk.conf" I also tried to specify where to find GCC this way in the mk.conf :
For SFW GCC 3.4 :


For OpenCSW GCC 5.2 :


Didn't work...(Circular dependency detected)

I can send you any log file (or conf) you want, just tell me which one you want.

Otherwise I can try "USE_CWRAPPERS = no". It's not supposed to change anything but... well if it work it might help to pinpoint where the problem is.

On Wed, Sep 13, 2017 at 4:37 AM, Jonathan Perkin <> wrote:
* On 2017-09-13 at 07:58 BST, Thomas Mueller wrote:

> > On Tue, Sep 12, 2017 at 06:43:25AM +0000, Thomas Mueller wrote:
> > All packages, including pkgtools/cwrappers itself, seem to depend on cwrappers.
> > No, it doesn't.
> Last time, starting on a pristine NetBSD 8.99.1 amd64 installation
> (no packages installed), I was stuck on the cwrappers circular
> dependency.
> Only way past the circular dependency was to build
> pkgtools/cwrappers with USE_CWRAPPERS = no
> then reenable cwrappers.
> Has that situation been fixed in the past three weeks or
> thereabouts?

No.  If you look at this section of mk/

  # Enable cwrappers if not building the wrappers themselves, and if the user has
  # explicitly requested them, or if they haven't but the compiler/platform is
  # known to support them.
  .if empty(PKGPATH:Mpkgtools/cwrappers) && \
      (${USE_CWRAPPERS:tl} == "yes" || \
      (${USE_CWRAPPERS:tl} == "auto" && \
       ${_OPSYS_SUPPORTS_CWRAPPERS:Uno} == "yes"))
  _USE_CWRAPPERS=         yes
  _USE_CWRAPPERS=         no

you can see that it's impossible for the pkgtools/cwrappers package to
depend on itself.  That code hasn't changed substantially since 2015.

What likely has happened is that you are missing some fundamental tool
that pkgsrc requires, and that has caused extra dependencies to be
inserted prior to cwrappers.  In the past we have actively worked
around these (e.g. by setting PKGSRC_LOCKTYPE=none), so if you are
able to reproduce this issue and send us the full log we can see if
there's an edge case we've missed.


Jonathan Perkin  -  Joyent, Inc.  -

Home | Main Index | Thread Index | Old Index