pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: installing spamassassin on amd64 7.0

On Mon 03 Oct 2016 at 13:00:41 +0100, Steve Blinkhorn wrote:
> Every time I have attempted to install spamassassin I have run into
> difficulties with mutiple Perl modules either absent, nor not matching
> the current version of Perl or some such.

> # pkg_add -u -u spamassassin
> pkg_add: Dependency of p5-BerkeleyDB-0.54 fulfilled by perl-5.20.1, but not by p erl-5.24.0
> pkg_add: Can't install dependency perl>=5.24.0

> Where am I going wrong?

I have installed spamassassin by compiling all packages myself, so maybe
there is a difference already in that. But it seems like you have
perl-5.20.1 instead of perl>=5.24.0. I only get perl-5.24.0.

Maybe you can look which package pulls in the older perl. Try removing
the older perl and manually reinstalling the newer one. Hopefully now
whatever got you the older perl is also happy with the newer one.
I expect that spamassassin will be happier too.

> Steve Blinkhorn <>
___ Olaf 'Rhialto' Seibert  -- Wayland: Those who don't understand X
\X/ rhialto/at/    -- are condemned to reinvent it. Poorly.

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index