pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Strange errors while compiling security/p5-GSSAPI

On Wed, 3 Aug 2016, Greg Troxel wrote:
> > Note that this patch is backwards!  You are adding a bl3 line....

Huh, I must have fat-fingered the order of the files. However, it is an 
obvious one-liner as you pointed out. 

> FWIW, p5-GSSAPI builds fine on netbsd-6 and netbsd-7 with no 
> KRB5_DEFAULT setting.

Hmm, weird. I often use 'pkgin' to install some packages (things that take 
eons to build like qt4). I've noticed that the repos often have (much) 
older pkg files in them versus what's in the matching CVS tagged release 
(ie.. pkgsrc-2016Q2). For example, pkgin pointed at the 2016Q2 "All" 
directory for i386 installed an older version of Perl than what I got when 
I ended up removing the pkgin-installed-version and re-installing with 
"make install" from the pkgsrc dir (and it picked a newer release revision 
for perl than pkgin installed). I'm not sure why this is, but I've seen it 
break pkgsrc builds at least 5-6 times since I've started using pkgin. 
Ie.. what seems to happen is pkgin installs an older copy of something, 
then pkgsrc-raw (ie.. compiling directly from source with a 'make 
install') fails/breaks with some complaint about how XYZ is older than 
what it wants for a dependency.

What I can't understand is how those old packages are getting in there 
(ie.. pkgin and pkgsrc at the same revision-level should agree on package 
dependencies ... or at least that's what I thought). I thought folks just 
had a fast-build-server somewhere and built the pkgsrc packages the same 
as a user would do, only faster and more complete/automated. However, what 
I now suspect is folks are perhaps short-cutting those build processes by 
using dependencies/files/packages from older pkgsrc dists. Either it's 
that or CVS tagged releases of pkgsrc could be evolving more than I 
believed and the original pkg files built for pkgin repos have basically 
just aged out vis-a-vis what's happened to the pkgsrc CVS tree. Put a 
different way, perhaps folks aren't re-visiting the re-building the pkgin 
repos after the same branch experiences significant changes in CVS. 

Then again, maybe I've just horked up my box and it's totally just 
something I did. That's always possible.

> Do you have anything in your mk.conf?  What OS/version?  Do you have a 
> krb5 package installed?

my /etc/mk.conf: 

I also tried adding KRB5_DEFAULT=mit-krb5 off and on. That worked around 
the issue also, as you suspected.

I'm surprised it works on stock NetBSD, but I believe you. I use the snot 
outta my NetBSD workstations and often make a lot of changes. It could 
totally have been something I did. However, the strange thing is that, for 
me, I can easily reproduce the error by using the stock pkgsrc-2016Q2 
source tarball, a cvs update -dP, and no KRB5_DEFAULT in my /etc/mk.conf. 
That fails predictably every time and fails to get the include files 
etc... just like your original suspicion, because there is no buildlink3 
kit for the include files.

Thanks again for your help folks. I appreciate it. 


Home | Main Index | Thread Index | Old Index