pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Strange errors while compiling security/p5-GSSAPI

Today I tried to compile devel/p5-GSSAPI and something strange happened. I 
got this error (this is pkgsrc-2016Q2, after cvs update -dP):

--- GSSAPI.o ---
gcc -c  -I/usr/pkg/include  -O2 -pthread -I/usr/include -fwrapv 
-fno-strict-aliasing -pipe -fstack-protector -I/usr/pkg/include 
-D_FORTIFY_SOURCE=2 -O2  -I/usr/pkg/include -I/usr/include 
-I/usr/include/krb5    -I/usr/pkg/include -I/usr/include 
-I/usr/include/krb5    -DVERSION=\"0.28\"  -DXS_VERSION=\"0.28\" -DPIC 
-fPIC "-I/usr/pkg/lib/perl5/5.24.0/i386-netbsd-thread-multi/CORE"   
GSSAPI.xs:34:35: fatal error: gssapi/gssapi_generic.h: No such file or 
 #include <gssapi/gssapi_generic.h>
compilation terminated.
*** [GSSAPI.o] Error code 1

However, right after that I went into the work/GSSAPI-0.28 directory and 
did a "make" by hand. That worked with no issue. It was only when I did 
the make in the parent/pkgsrc directory that it failed. The header file it 
mentions is definitely in pkg/include/gssapi. 

Does anyone have an idea why this might have been the case? Is it 
something worth looking into or just an issue with my rig? Thanks! 


Home | Main Index | Thread Index | Old Index