pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/53812: vncserver consistently crashes

>Number:         53812
>Category:       pkg
>Synopsis:       vncserver consistently crashes
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Dec 26 04:05:00 +0000 2018
>Originator:     Da Engholm
>Release:        2018-Q3
NetBSD localhost 8.0 NetBSD 8.0 (GENERIC) #0: Tue Jul 17 14:59:51 UTC 2018 amd64
Xvnc crashes consistently producing a core file. This occurs with net/vnc built from sources and installed as a binary package using pkgin. I have seen this for several years now, though I can't recall now when it started. I have a NetBSD-7.0.2 host with vnc- which functions. I can copy the Xvnc binary on that system to a newer system, overlying the non-working Xvnc binary then VNC server works fine.

I've tried this with several VNC viewers: gvncviewer and RealVNC on Ubuntu 16.04.5 LTS, RealVNC on Android, vncviewer on NetBSD 8.0 with identical results.

As consistently as this has failed for me for years, I am surprised that searches on Google have not turned up any other complaints, nor have I seen anything come up in pkgsrc-users.
I did this with a VMWare guest. Having gone through it several times with
the same result, I don't believe that the particulars (CPU count, memory
size, file system capacity) make any difference. I have also demonstrated this on NetBSD 8.0 and older running in a XEN user domain (running on a NetBSD 6.1.4 host).

* install NetBSD-8.0 (several previous versions also demonstrate the
  + select installation of binary packages (pkgin)
* log in and install vnc package (pkgin install vnc)
* start a VNC server (vncserver :1)
* check to make sure Xvnc is running (pgrep -fl vnc;netstat -anfinet)
* connect a vncviewer to the vncserver
* note that Xvnc is no longer running (pgrep -fl vnc;netstat -anfinet)
* note that Xvnc.core has been created
I know of no way to work around this problem besides using a copy of Xvnc built in 2009.

Home | Main Index | Thread Index | Old Index