pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/39890

The following reply was made to PR pkg/39890; it has been noted by GNATS.

From: "Michal Suchanek" <>
Subject: Re: pkg/39890
Date: Thu, 20 Nov 2008 23:55:08 +0100

 > >  The Ruby 1.8.7 available in pkgsrc is not 1.8 compatible.
 > If you build Ruby 1.8.7 out side of pkgsrc framework, "not 1.8
 > compatible" problem will be gone a way?  If not,
 No, it does not.
 > >  While most 1.8 code runs in 1.8.7 with only minor tweaks lots of 1.8.7 
 > > code would not run in older 1.8 rubies which makes 1.8.7 completely 
 > > unsuitable for Ruby development.
 >  These problems are inherently the problem of Ruby itself.  AFAIK, many
 No, it is not. 1.8.6 is readily available on the Ruby web site.
 >  Ruby programs are updated to supoprt newer Ruby 1.8.7 (or 1.9 preview).
 Yes. I do not doubt that. On the other hand, I have not heard of a
 program that requires 1.8.7. And code written for 1.8.7 (using 1.8.7
 documentation) has high chance of failing on 1.8.6 or earlier.
 > >  On some platfroms ruby 1.8.7 is not available and it is not desirable to 
 > > install this version for most Ruby users (as far as I can tell from the ML 
 > > discussions).
 > What is the "some platfroms"
 "some platforms" include Windows, and probably packaging systems that
 are not as eager to pick bleeding edge stuff ;-)
 > and "the ML discussions"?
 > > >Fix:
 > > roll back ruby to 1.8.6 or provide a separate 1.8.6 package
 > Retiring ruby 1.8.7 to 1.8.6 pillage the use of functionality of Ruby
 > 1.8.7 and I don't think it is realistic approach.
 Packaging an incompatible version of the interpreter does not seem
 realistic either.

Home | Main Index | Thread Index | Old Index