NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Option -p in apropos(1)

On mag 16 18:11, Rocky Hotas wrote:
> Am I doing something wrong?

Some very funny updates.

First, I'm on NetBSD 9.2 amd64 (but I also tested the same things in
another machine with NetBSD 9.0 amd64).

The first time I run `apropos' with option `-p', it doesn't work (as
written in the previous message). In a newly created terminal (an
st(1) instance) it may print:

perl5320delta (1)       what is new for perl v5.32.0
...Configure  4 For clang++, add "#include <stdlib.h>" to Configure's
probes for "futimes", "strtoll", "strtoul", "strtoull", "strtouq",
otherwise the probes would fail to compile.  4 Use a compile and run
test for "lchown" to satisfy clang++ which should more...

--More--(byte 3792)myhostname$

Where `myhostname$' is my bash prompt. So, more(1) tries to start, but
it immediately exits.

If I run apropos(1) for a second time, changing the argument, then it
works as expected: more(1) is active and the screen can be scrolled.

The argument change is essential, because if I run apropos(1) a second
time with the same argument, the output ends again with

--More--(byte 3792)myhostname$

as before. Also, if I run

apropos -p argument1
apropos -p argument2
apropos -p argument1

the last time I get again

--More--(byte 3792)myhostname$

as if this was related to some dislike towards argument1.


Home | Main Index | Thread Index | Old Index