NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: thinkpad : e470 : bootup : barfs at acpi


On 04.02.2018 05:34, Kathe wrote:
i am at the first-boot via netbsd 7.1.1 using thumbdrive.
i tried the "without acpi" option and the boot moved further than before.
but, barfed again at "root device" (i think based on my limited recollection).

Just one guess: I have experienced a similiar issue when installing NetBSD to a pretty modern Intel NUC device. In my case the root cause was that the device exclusively has a XHCI (USB 3.0) controller, but no UHCI / EHCI. As NetBSD 7.x only offers support for UHCI / EHCI, the USB 3.0 controller was not recognized at all and rendering the kernel unable to find a device where to look for the root filesystem. The reason why the kernel is still loaded from the USB 3.0 is that the bootloader is probably using some BIOS / CSM compatibility stuff.

Could you try NetBSD 8.0 Beta[1] on the same device? The amd64 build has XHCI enabled by default and this worked for my case.

Kind regards,



Matthias Petermann <> |
GnuPG: 0x5C3E6D75 | 5930 86EF 7965 2BBA 6572  C3D7 7B1D A3C3 5C3E 6D75

Home | Main Index | Thread Index | Old Index