NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Help! I can't boot my Windows partition any more!

from MLH:

> I have no idea if it is related, but at least on both of my Netbsd
> 7 systems, both amd64 and i386, installboot appears to destroy the
> bootblock on at least the usb drives I have tried, rendering those
> drives unbootable. I ran out of expendible external drives and
> really don't want to try another drive. I haven't tried a usb memory
> stick as I have never tried to get one to be bootable.

I've had good luck installing NetBSD and FreeBSD to USB sticks so as to be bootable on their own.

For NetBSD, using gpt, I make root partition and swap partition, not sure if swap partition is needed.

I run newfs on root-to-be partition, build and install from source, run installboot.

I don't know if this works as well on NetBSD <= 6.x, worked on 6.99.x so should be good on 7 and 7.99.x.

Also, I had a hard-drive installation of 7.99.1 amd64, copied the installation to USB stick for backup (prepared with gpt and newfs), ran installboot, and it booted successfully.

Installing NetBSD to a USB stick is much slower than to a hard drive.


Home | Main Index | Thread Index | Old Index