NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index] vs. read-only fs netbsd-7


I just updated my src tree to netbsd-7. After clearing everything away from /usr/obj, I attempted a build. Here are some details...

  o amd64 system
  o netbsd-7 branch as of last night
  o /usr/src is mounted read-only
  o nothing special in mk.conf
  o recent netbsd-6 builds worked fine

$ ./ -u -U -T /usr/obj/TOOLDIR.amd64 -O /usr/obj tools

(worked fine)

$ ./ -u -U -T /usr/obj/TOOLDIR.amd64 -O /usr/obj release

This one fails here...

#       lex  backend//usr/src/external/gpl3/gcc/dist/gcc/gengtype-lex.c
/usr/obj/TOOLDIR.amd64/bin/nblex -o/usr/src/external/gpl3/gcc/dist/gcc/gengtype-lex.c /usr/src/external/gpl3/gcc/dist/gcc/gengtype-lex.l
nblex: could not create /usr/src/external/gpl3/gcc/dist/gcc/gengtype-lex.c

Why's it writing to /usr/src/ rather than somewhere in /usr/obj?

Any help would be great. Thanks,


Home | Main Index | Thread Index | Old Index