NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NetBSD as NIS server, FreeBSD as client


Last sunday, I have tried to install a NIS server on my Blade 2000 (sparc64 running last daily snapshot and kernel 6.99.49). I have configured rpc and both nfs server and nis server.

On FreeBSD side (as NetBSD/i386 does not boot on this Acer Aspire 1700), I have installed a nis client, but I'm not able to run ypcat on client. Thus, NIS client does not work.

Of course, I have written hosts.allow and hosts.deny. rpcbind on server side seems to run as expected as I can mount home directory on nis client. ypserv and some others programs are registered and appear in rpcinfo output.

But if I start on client ypbind, tcpdump only reports UDP broadcast on sunrp port. NIS server does not send any message.

I don't have any firewall. I have tried with a hosts.allow that contains ALL: ALL without any result.

        I don't understand my mistake. All ideas are welcome.

        Best regards,


Home | Main Index | Thread Index | Old Index