NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: proplem with ntpd refclock and pps via parallel port

On 31 Jan 2010 at 17:03, David Lord wrote:

> On 31 Jan 2010 at 16:08, David Lord wrote:
> Possibly this should be "sorry for the noise" as I've
> just tried with symlink to /dev/tty00 and have exact 
> same failure of refclock.
> I'll try with parallel port on another system 
> currently working ok with refclock via serial port, 
> but no pps. I'm limited to what I can try as it's
> online.

That was using serial DCD from MSF radioclock. On
swapping to using serial DSR for timecode and 
almost good pps output to serial DCD after restart
of ntpd an 'ntpq -p' showed SHM(0) and PPS(0),
eventually +SHM(0) and oPPS(0).

> I have other system that I originally tested with
> refclock but that's a distance away but I can at 
> least try with different kernel and feed in 1Hz 
> from sig-gen.

Tried this with gps-18x-LVC with serial RxD and
nmea driver plus pps to serial DCD. All ok.

Swapped simlinks from pps0 -> tty00 to pps0 -> lpt0
and stayed at oPPS(0) with reach 377. 


Went back to pool server, fitted parallel cable,
and swapped simlinks from pps0 -> tty00 to 
pps0 -> lpt0 and had the same error as when tried
before. Scrathes head, what's different between
upstairs vs down here. Upstairs I had a breakout
adaptor I'd taken pps from but left serial DCD
connected. So connecting pps back to DCD as well
as NACK on parallel port and pool server now
showing synced to PPS.

Now I don't know if pps is being picked up from
serial DCD or parallel port.


Home | Main Index | Thread Index | Old Index