NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Corrupting Files

I have tried removing softdep from the mount options, but from the results of last night it is still happening, if not worse.

Currently disabled write-back cache on all 4 HDDs and see if it helps. We also just paniced. fsck takes about 2 hours.

If it were a 48bit LBA, or generally bad partitioning I would have expected much larger corruption, rather than a few bytes in the middle of files ..?

So far, it seems to be confined to wd2 and wd3. I am re-testing everything on wd0 and wd1 just to be sure.

Dave B wrote:
On Mon, Dec 22, 2008 at 08:02:20PM +0900, Jorgen Lundman wrote:
It tests the uploaded file good, md5sums are equal. I even tried setting O_SYNC, and mode 0400 during, and after, upload, as a test. The file is correct on disk for several minutes. Even after "sync". Then suddenly it gets changed.

  What's the disk caching setup--per "dkctl wd0 getcache" (or
whatever applies given the disk you're using: "wd1", "scsictl
sd0 ...", etc.)?

And, if the write-back cache was enabled, does disabling it
(e.g., "dkctl wd0 setcache r") change the behavior?

Cheers,  --Dave

Jorgen Lundman       | <>
Unix Administrator   | +81 (0)3 -5456-2687 ext 1017 (work)
Shibuya-ku, Tokyo    | +81 (0)90-5578-8500          (cell)
Japan                | +81 (0)3 -3375-1767          (home)

Home | Main Index | Thread Index | Old Index