NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD and ASUS's EeeBox


Le Sam 6 septembre 2008 1:48, Anders Lindgren a écrit :
> On Fri, 5 Sep 2008, Joel CARNAT wrote:
>> Wireless works since you patch your source tree with the patch that is
>> indicated on the Eee support status page.
> No luck for me there.
>> I keep a copy of my 4.99.72 kernel here :
> I tried your kernel -- I get the exact same failure as with 4.99.72
> GENERIC+atheee.patch from 20080816, and a GENERIC+atheee.patch kernel I
> built tonight just for reference:
> - if WEP encryption is enabled in the AP, wiconfig ath0 -D finds nothing
> unless I first set both ssid and nwkey on the interface in advance. After
> ssid+nwkey are set, it does find the AP -- but not always on the first
> run.
> - setting the nwkey with ifconfig produces the error(?) "setting keyix 0
> w/o power".
> - If I turn off WEP, wiconfig ath0 -D immediately finds the AP.
> - dhclient has problems acquiring an IP address, and must sometimes be
> run 2-3 times before succeeding.
> - after the network is finally up, a constant 32-35% packet loss is
> experienced, seemingly in bursts. This is app. 4m from the AP, and the old
> laptop has 0% packetloss everywhere in the house.
> - while any kind of traffic is passing over the interface (also during
> DHCPDISCOVER), spurious
>    "ath0: device timeout (txq 1, txintrperiod N)" (N=1..5)
> messages are produced. Setting txintrperiod to 1 on boot in sysctl.conf
> seems to improve the rate at which it happens, sometimes.
> I've tried disabling ACPI on boot (remembering old posts about interrupt
> routing problems), but I didn't notice any difference apart from
> "poweroff" failing to actually power off the computer. It just halts and
> prompts for a keypress to reboot instead.
> Very weird that your kernel works on your eee900 but not mine. I will test
> these kernels on other networks this weekend to rule out incompatibility
> with this particular old DLink900AP+ (802.11b AP), but it looks a lot more
> like an interrupt problem given the frequent TX queue device timeouts.

Well, from what I understood, the only thing that doesn't work on yours in
WEP connection to a WLAN, right ?

I don't do WEP here, I only use WPA2-Personnal (with a Linksys box).

Try using WPA or clear network instead of WEP to see if that's the issue.


Home | Main Index | Thread Index | Old Index