NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/56209: erratic usb operation

>Number:         56209
>Category:       kern
>Synopsis:       erratic usb operation
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue May 25 15:00:00 +0000 2021
>Originator:     Joseph Sarkes
>Release:        9.1
unavailable atm, just the amd64 download for 9.1
usb has irregular timeout messages with multiple mice of different manufacturers on console. the mice operate properly it seems. there ends up a lot of green messages on the console for connect / disconnect of the mice though.

a possibly related problem is a usb prologix gpib adapter has erratic operation where much corruption takes place semi randomly. using the prologix ++help command in minicom or a c program written to communicate with it results in around 1/3 of the help message displayed, the rest lost. this prologix device seems to work fine displaying the full help message in minicom on linux (i finally broke down and tried linux for troubleshooting.) i suspect the same thing that is messing with the mice is breaking the prologix (some type of timeout). my eyes cross when i try to trace through and find the driver stuff in kernel source.

if you need more info (if this isn't known about already, i tried to search but found nothing on my attempts) feel free to email for more info and to try stuff/report messages, etc. i remember netbsd serial being rock solid so this seems weird to me but it IS usb.
for mice just plug in a mouse. both a cheap targus and something else i have that i can't find atm timeout.

if you have a prologix gpib adapter just run minicom or what have you and use the ++help command and likely it will be truncated. if it is working elsewhere it is a hardware issue with my toshiba laptop.

the prologix device is what i really need working. it is an ftdi serial / usb adapter chip talking to another programmed logic chip.
run linux? if i could get through the drivers properly i'd give it a try but i just go slackjawed. honestly i have always preferred netbsd with the standard loadout of unix apps and then some packages. linux is too different for me and bloated with all sorts of stuff loaded in. 

Home | Main Index | Thread Index | Old Index