NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: install/55478: netbsd 9.0 - Installer freezes on macbook pro late 2013

The following reply was made to PR install/55478; it has been noted by GNATS.

From: Marko Bauhardt <>
To:, Andrius V <>,,,
Subject: Re: install/55478: netbsd 9.0 - Installer freezes on macbook pro
 late 2013
Date: Thu, 16 Jul 2020 19:07:34 +0200 (CEST)

 > Andrius V <> hat am 11.07.2020 15:10 geschrieben:
 >  I would recommend trying UEFI image, since I had better results
 >  booting from it on Mac Mini 2014 system, in case you haven't tried
 >  yet. I had a black screen issue as well in previous releases, though
 >  using UEFI image, not a BIOS boot. Don't remember anymore if it was
 >  fixed in NetBSD 9 release or current branch.
 I tried several 9.0 images. The usb-uefi version, the usb-bios version and the cdrom version. Same issue.
 But, on the bios one, I got log messages. It turns out the issue is the same as
 I'm pretty sure the installer wants to know where the root device is
 boot device: <unknown>
 root device:
 and expect that the user type the name of the device. But as far as I know the built in keyboard on this macbook pro is a usb 3 keyboard. And this is disabled while booting.... maybe...
 I had the same thing when I tried to install OpenBsd.
 Btw, FreeBsd doesn't have this issue.
 So I can't obvisely don't plugin an external USB keyboard because USB is disabled??
 Any Idea how I can workaround this issue, maybe providing a disk layout where the installer does not run into the interactive session. I could use the FreebSD live installer to prepare the disk.
 Any idea/comment?

Home | Main Index | Thread Index | Old Index