NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: install/55478: netbsd 9.0 - Installer freezes on macbook pro late 2013

Unfortunately, I can't comment much. In case NetBSD asks for a boot
device, it usually means that it couldn't recognize it. Thus, it is
very likely that the USB3 controller wasn't recognized/attached for
some reason (keyboard seems to work on USB2 internally). 51716 was
submitted during NetBSD7 times, USB3 driver greatly improved since
then and was enabled by default (wasn't the case in NetBSD 7). I had
very similar issues with Mac Mini and they were resolved by now. And
according to messages from that bug, the system was hanging on pre
NetBSD 8 system (which probably already had USB3 enabled), which is
not the case for you. Since, there's no easy way to save log messages
in this situation, maybe making a video probably is also one of the
solutions to analyze if xhci appeared somewhere in the logs (booting
with -vx may give more info). If you have some spare thunderbolt 2
device, you may have more success booting from it as well.

Finally, you can try netbsd-current images to see if the problem still
persists and how it behaves with the latest code.

On Thu, Jul 16, 2020 at 8:32 PM Marko Bauhardt
<> wrote:
> The following reply was made to PR install/55478; it has been noted by GNATS.
> From: Marko Bauhardt <>
> To:, Andrius V <>,
> Cc:
> Subject: Re: install/55478: netbsd 9.0 - Installer freezes on macbook pro
>  late 2013
> Date: Thu, 16 Jul 2020 19:07:34 +0200 (CEST)
>  > Andrius V <> hat am 11.07.2020 15:10 geschrieben:
>  Hi,
>  >
>  >  I would recommend trying UEFI image, since I had better results
>  >  booting from it on Mac Mini 2014 system, in case you haven't tried
>  >  yet. I had a black screen issue as well in previous releases, though
>  >  using UEFI image, not a BIOS boot. Don't remember anymore if it was
>  >  fixed in NetBSD 9 release or current branch.
>  I tried several 9.0 images. The usb-uefi version, the usb-bios version and the cdrom version. Same issue.
>  But, on the bios one, I got log messages. It turns out the issue is the same as
>  I'm pretty sure the installer wants to know where the root device is
>  boot device: <unknown>
>  root device:
>  and expect that the user type the name of the device. But as far as I know the built in keyboard on this macbook pro is a usb 3 keyboard. And this is disabled while booting.... maybe...
>  I had the same thing when I tried to install OpenBsd.
>  Btw, FreeBsd doesn't have this issue.
>  So I can't obvisely don't plugin an external USB keyboard because USB is disabled??
>  Any Idea how I can workaround this issue, maybe providing a disk layout where the installer does not run into the interactive session. I could use the FreebSD live installer to prepare the disk.
>  Any idea/comment?
>  Thanks
>  Marko

Home | Main Index | Thread Index | Old Index