Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: cvs update aborted by broken pipe on server

> On Tue,  1 Dec 2020 00:44:26 +0000 (UTC)
> "Thomas Mueller" <> wrote:

> > What causes this problem that sometimes occurs when I (attempt to) update src tree by "cvs up -dP -A"?
> > Ending lines of screen output may be
> > cvs update: Updating external/gpl3/gdb.old/dist/gdb
> > P external/gpl3/gdb.old/dist/gdb/.dir-locals.el
> > U external/gpl3/gdb.old/dist/gdb/CONTRIBUTE
> > U external/gpl3/gdb.old/dist/gdb/ChangeLog
> > U external/gpl3/gdb.old/dist/gdb/ChangeLog-2017
> > Write failed: Broken pipe
> > cvs [update aborted]: end of file from server (consult above messages if any)
> > Sometimes or often, I may complete the update by repeating "cvs up -dP -A" command one or more times.

> If it helps (that was one of my original problems) for me it seems to happen pretty consistently with a specific version of NetBSD:

> germ$ uname -a
> NetBSD germ 8.99.51 NetBSD 8.99.51 (GENERIC) #2: Thu Jul 18 16:25:29 PDT 2019  german@germ:/home/german/work/netbsd/src/sys/arch/amd64/compile/obj/GENERIC amd64

> But not the one I use on this box for instance:

> Nima: {2}  uname -a
> NetBSD Nima 9.99.76 NetBSD 9.99.76 (GENERIC) #1: Thu Dec  3 13:44:49 UTC 2020  german@Nima:/usr/src/sys/arch/amd64/compile/obj/GENERIC amd64

> (broken runs on wm0 (intel?) Ethernet ; working, on Atheros Wireless
> I haven't tried in a while but figured I would pinch that in )

> Kindest regards,

> Germain <>

If you repeat "cvs up -dP -A" one or more times after getting the broken pipe, does that work?

I have NetBSD 8.99.51 installed, both amd64 and i386, but am now in 7.99.1 to avoid the crash "Error reading fsbn ..." that I get with 8.99.51, though it make take several days before that crash.

On the other computer, I run "cvs up -dP -A" mostly from FreeBSD 11.1-STABLE (now outdated).  There is no cvs in FreeBSD base system; I built the package from FreeBSD ports.

On this computer, if I boot 8.99.x GENERIC, the result is immediate reboot, no console messages.  I have to use custom kernel and (userconf) disable athn.


Home | Main Index | Thread Index | Old Index