Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

More NVMM testing

I’ve been doing some more testing of NVMM on a system running NetBSD-9.99.41.  Basically I’m trying to install a Mac OS-X 10.6 system.  I’m doing this on a Mac that I own with the retail distribution DVD that came with that Mac, so I believe I’m compliant with Apple’s EULA.  This installation is, as far as I can tell, no different from running OS-X inside of Parallels or VirtualBox which seems to be legal and acceptable to Apple.

This is NOT a Hackintosh install, and I’d strongly suggest that anybody attempting something similar make sure they feel comfortable with their approach and Apple’s EULA.

My approach has been to follow the instructions found in these web pages:

What I’ve found so far is that I’m able to successfully install and run OS-X on a LinuxMint 19.3 system with KVM using the Chameleon boot code referred to in these pages, but have been unsuccessful using the OVMF boot code. Could just be a cockpit error on my part, but since Chameleon worked I stuck with it for my testing.

I then moved to my NetBSD-9.99.41 system and tried the same thing just changing the accelerator from KVM to NVMM.  It fails both installation or attempting to run from the OS-X disk I created under LinuxMInt KVM.  The only diagnostics I see are:

qemu-system-x86_64: NVMM: Unexpected RDMSR 0x35, ignored
qemu-system-x86_64: NVMM: Unexpected RDMSR 0xce, ignored
qemu-system-x86_64: NVMM: Unexpected RDMSR 0x194, ignored
qemu-system-x86_64: NVMM: Unexpected RDMSR 0x1ad, ignored
qemu-system-x86_64: NVMM: Unexpected RDMSR 0x198, ignored

The boot on NetBSD under NVMM appears to start OK (I see the spinning cursor), but then it quickly bails out and goes back to the boot loader screen.

Would love to see NVMM working like KVM works in this case.  Is there anything more I can provide or any additional testing I can do that might help?


Home | Main Index | Thread Index | Old Index