Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: unable to boot amd64-uefi-install from USB stick on a MacBook2,1

So, I tried various ways of getting this macbook2,1 to boot a non-EFI
image from USB, including using rEFIt installed on the hard disk.  It
just can't do it.  rEFIt (I'm assuming) displays the following message
after giving up "The firmware refused to boot from the selected volume.
Note that external hard drivers are not well-supported by Apple's
firmware for legacy OS booting".

Unfortunately I also don't have enough space on the internal disk to
make room for a separate NetBSD partition as per the instructions here:

However I finally remembered that I do have a not-incredibly-ancient DVD
with an install image of NetBSD/amd64 from about 7.99.5.

This boots and runs just fine.

So, just to be "sure" it wasn't a UEFI vs. BIOS boot issue I burned a
DVD of the install ISO image for the same version I've been trying to
boot the uefi-installimage of.

When booted by holding "c" at the chime, this does not work.  It boots
to something that displays (in the same "VGA"(?) video mode seen when
the boot loader runs from the 7.99.5 DVD):


Select CD-ROM Boot Type : _

and then seems to hang and is unresponsive, though the under-bar cursor
continues to blink.

However since I now have rEFIt installed on the hard drive, I can boot
that and it then gives me the option of booting one of two EFI boot
loaders from the DVD, so I chose the 32-bit one (the firmware in this
macbook will not run 64-bit EFI boot loaders) and it boots the primary
"NetBSD/x86 EFI Boot" loader.  This gets me to the same place I get with
the EFI boot from USB:  I.e. the screen clears, the non-blinking block
cursor is shown, and the system seems to hang.

So it would seem that sometime between 7.99.5 and now, or indeed between
7.99.5 and 8.0 (I tried the NetBSD-8.0-uefi-install.img from the FTP
site) the amd64 kernel has stopped working on older macbooks.

I'm not quite sure where to go from here.

If I knew exactly where the video mode was being changed, and assuming
the console could start printing right then and there if forced to be
attached early, I might try adding printfs to see if I can trace to
where it hangs, but that process seems quite tedious unless I can find a
quicker way to update the kernel directly on the USB stick without first
re-building the whole image then copying it very slowly to the USB stick
(it goes at about 5MB/s).  (Unfortunately the ufs.kext in the
latest macOS 10.6.8 that'll run on this machine won't mount NetBSD a

The next best would be to examine the diffs between 7.99.5 and 8.0 I
guess, but I'm not too sure where to start.

					Greg A. Woods <>

Kelowna, BC     +1 250 762-7675           RoboHack <>
Planix, Inc. <>     Avoncote Farms <>

Attachment: pgphEknlt7jiX.pgp
Description: OpenPGP Digital Signature

Home | Main Index | Thread Index | Old Index