Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: File corruption?

FWIW, the last 'completely stable' -current on RPi 3B+ has been 9.99.17 as well.  I don't know what has happened, but there seem to be some regressions from that time onward.


On Thu, Jan 16, 2020 at 6:20 PM Robert Nestor <> wrote:
I’ve got NetBSD-9.99.17 (amd64) installed and it  has been running without any problems which i have been using to work with NVMM.  I do package builds on it using pkgsrc-current and also do the build of wip/qemu-nvmm.

This morning I installed NetBSD-9.99.38 (Jan 15th build) on another disk.  I copied my current copy of pkgsrc over to the new disk to build some of the packages I use under the new system.  When I went into the pkgsrc/wip directory and did a “git pull -r” it complained about file corruption.  I tired the same command in the pkgsrc/wip directory on my 9.99.17 system and got the same error.  I rebooted into the 9.99.17 system and the update ran fine.  Under the 9.99.38 system I tried just downloading a new checkout of the wip directory and it failed with file corruption errors similar to when I tried to do an update.

The package builds under 9.99.38 with all the recent changes do run a heck of a lot faster, but it seems like there might be an underlying problem that causes file corruption.  Assuming this is the case, is there something I can do to help uncover what might be going on?


Home | Main Index | Thread Index | Old Index