Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: dhcpcd ignores "force_hostname=YES" on diskless clients?

On Sun, 22 Sep 2019, Roy Marples wrote:

> If the hostname is "localhost" then dhcpcd won't send it.
> If the hostname is "localhost" then dhcpcd will set the hostname given via

The hostname is not and never has been "localhost" but that's what it was
explicitly set to when 'dhcpcd' was doing the post-netboot configuration.
(Without "force_hostname=YES" it would have done nothing at all and left
it set to the short name obtained by the kernel's DHCP client.)

Observed on multiple boots on sparc-current before recent imports of
newer 'dhcpcd'.  I don't recall which version it was running at that
point.  It worked properly before then and works properly now, but there
was a period where it didn't work.

As for the i386 system, it hadn't actually been using 'dhcpcd', so was
always keeping its short name from the kernel DHCP client.  Once I
actually enabled 'dhcpcd' (dhcp keyword in "/etc/ifconfig.<ifN>"), it
worked as expected and set the hostname to the FQDN.

> So the only config change you should need to make by default is uncommenting
> ntp_servers.

I don't want 'dhcpcd' exfiltrating my hostname (it's nobody else's
business), so I always comment out the "hostname" directive.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]consolidated[flyspeck]net  OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index